UEFI: agFM/Ventoy Menu not loading or ISOs not running [on one particular system]

If you have checked the UEFI/BIOS settings and they appear to be correct for UEFI-booting, but when you try to UEFI-boot you find that the agFM menu does not appear or when you select an ISO it does not seem to boot (or the USB drive LED flashes for a while and system hangs), or other strange things occur with agFM or Ventoy, then I recommend you reset the BIOS settings.

Go to BIOS Setup menu and find the ‘Exit’ Menu, then choose the ‘Load Default Settings’ option (or similar) and any other ‘default’, reset or Factory settings options you can see.

Then save the changes and reboot back into the BIOS Setup menu and ensure the settings are correct for Legacy and UEFI booting.

USB Legacy: enabled
Fast Boot: disabled
Boot Mode: Legacy (CSM) – if you want Legacy booting
For Secure Boot, I suggest you clear the DBx keys (if possible), or Restore Factory Keys

Please follow and like us:

Get the eBooks!

This website contains over 150 pages of information about Easy2Boot but a selection of easy-to-read eBooks are also available (in PDF format) (rated 4.5/5 stars by readers).
Learn the secrets of Legacy and UEFI USB booting and then make your perfect multiboot USB drive.
E2B eBook #1 includes instructions on how to remove the E2B blue 5-second start-up delay screen.

Most eBooks are over 100 pages long, contain original content and step-by-step exercises which are suitable for both the beginner or the more experienced user.
Customer reviews are located at bottom of each eBook product page and multi-buy discounts are available when you buy more than one eBook. Please also visit RMPrepUSB.com and the E2B Forum.
Subscribe to my blog for the latest news, tips, USB boot articles and free eBook updates.